Задать вопрос
7 декабря, 11:37

1. Имеются два числа. a) Вычислите сумму и разность этих чисел, используя два оператора readln. b) Перепишите программу так, чтобы использовался один оператор readln. c) Добавьте комментарии к программе. 2. Имеются три числа. Вычислите их произведение. 5. После начала некоторого эксперимента прошло t часов m минут и k секунд. Сколько всего секунд длится эксперимент? 6. Задано расстояние между городами в вёрстах. Переведите это расстояние в километры (точность: три знака после запятой) используя данные: 1 верста=500 саженям; 1 сажень=3 аршина; 1 аршин=0.7112 метра

+1
Ответы (1)
  1. 7 декабря, 14:11
    0
    1.

    uses crt;

    var a, b, s, r:real;

    begin

    write ('a:') ; readln (a) ;

    write ('b:') ; readln (b) ;

    s:=a+b;

    if a>b then r:=a-b

    else r:=b-a;

    write ('summa=', s,' raznost=', r) ;

    end.

    uses crt;

    var a, b, s, r:real;

    begin

    writeln ('vvedi chisla') ; readln (a, b) ;

    s:=a+b;

    if a>b then r:=a-b

    else r:=b-a;

    write ('summa=', s,' raznost=', r) ;

    end.

    uses crt;

    var a, b, s, r:real; {обозначение переменных}

    begin

    writeln ('vvedi chisla') ; {вывод текста на экран}

    readln (a, b) ; {чтение значений переменных}

    s:=a+b; {присваивание значения переменной суммы}

    if a>b then r:=a-b {условие для присваивания значения переменной разности}

    else r:=b-a;

    write ('summa=', s,' raznost=', r) ; {вывод текста на экран}

    end.

    2.

    uses crt;

    var a, b, c, p:real;

    begin

    write ('a=') ; read (a) ;

    write ('b=') ; read (b) ;

    write ('c=') ; read (c) ;

    p:=a*b*c;

    write ('proizv.=', p) ;

    end.

    5.

    uses crt;

    var t, m, k, d:real;

    begin

    write ('t=') ; read (t) ;

    write ('m=') ; read (m) ;

    write ('k=') ; read (k) ;

    d:=k+60*m+3600*t;

    write ('dlitelnost=', d,' sec') ;

    end.

    6.

    uses crt;

    var t, m, k, d:real;

    begin

    write ('t=') ; read (t) ;

    write ('m=') ; read (m) ;

    write ('k=') ; read (k) ;

    d:=k+60*m+3600*t;

    write ('dlitelnost=', d,' sec') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Имеются два числа. a) Вычислите сумму и разность этих чисел, используя два оператора readln. b) Перепишите программу так, чтобы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу для паскаль Известно, что 1 миля = 7 вёрст, 1 верста = 500 саженей, 1 сажень = 3 аршина, 1 аршин = 28 дюймов, 1 дюйм 25,4 мм. Пользуясь этой информацией, найти и перевести расстояния х миль в километры.
Ответы (1)
Известно, что 1 миля=7 верст, 1 верста=500 сажений, 1 сажень=3 аршина, 1 аршина=28 дюймов, 1 дюйм=25,4 мм. Пользуясь этой информацией, состаьте линейный алгоритм перевода растояния х миль в километры
Ответы (1)
Известно, что 1 миля = 7 вёрст, 1 верста = 500 саженей, 1 сажень = 3 аршина, 1 аршин = 28 дюймов, 1 дюйм 25,4 мм. Пользуясь этой информацией, составьте линейный алгоритм перевода расстояния х миль в километры.
Ответы (1)
В 17 веке основной мерой в России была казённая сажень равная 2.16 м. и содержащая три аршина (72 см) по 16 вершков. Еще во времена Петра 1 русские меры длинны были уравнены с английскими: 1 сажень=7 английских фунтов=84 дюйма=2.1336 метра.
Ответы (1)
В 17 веке основной мерой в россии была казенная сажень равная 2,16 м, и содержащая 3 аршина (72 см) по 16 вершков. Еще во времена Петра 1 русские меры длины были уравнены с английскими; 1 сажень=7 английским футов=84 дюйма=2,1336 метра.
Ответы (1)