Задать вопрос
6 декабря, 01:49

Умоляю помогите!

найти произведение всех элементов массива вещественных чисел, меньших заданного числа. Размерность массива - 10. Заполнение массива осуществить случайными числами от 50 до 100

+3
Ответы (1)
  1. 6 декабря, 04:12
    0
    const n=10;

    var a:array[1 ... N] of real;

    i:integer;

    x:real;

    begin

    randomize;

    for i : = 1 to n do

    a[i] : = random (100) - 50;

    readln (x) ;

    for i:=1 to n do

    if a[i]>x then p:=p*i;

    writeln (p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Умоляю помогите! найти произведение всех элементов массива вещественных чисел, меньших заданного числа. Размерность массива - 10. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Найти сумму всех элементов массива целых чисел, которые меньше среднего арифметического элементов массива. Размерность массива-20. Заполнение массива осуществить случайными числами от 150 до 300
Ответы (1)
Найти сумму четных элементов массива целых чисел. Размерность массива - 20. Заполнение массива осуществить случайными числами от 100 до 200
Ответы (1)
1. Количество единиц среди элементов массива. Заполнение массива произвести с клавиатуры. 2. Ко всем отрицательным элементам массива прибавить первый элемент. Заполнение массива произвести случайными целыми числами из [ - 6,6]
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)