Задать вопрос
18 октября, 07:16

выяснить есть ли в трёхзначном числе одинаковые цифры

+3
Ответы (2)
  1. 18 октября, 07:52
    0
    пишу на паскале

    program tralala;

    var a, b, c, n:integer;

    begin

    readln (n) ;

    a:=n div 100;

    b:=n div 10 mod 10;

    c:=n mod 10;

    if (a=b) or (a=c) or (b=c) then writeln (Есть') ;

    else write ('Нету') ;

    end.
  2. 18 октября, 11:15
    0
    var

    s:string[3];

    begin

    readln (s) ;

    if (s[1]=s[2]) or (s[3]=s[1]) or (s[3]=s[2]) then

    writeln ('Есть') else

    writeln ('Нет') ;

    end;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «выяснить есть ли в трёхзначном числе одинаковые цифры ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
В паскале! В любом трехзначном числе удалить первую цифру, а в оставшемся 2-х значном числе переставить цифры.
Ответы (1)
В трехзначном числе x зачеркнули его последнюю цифру. когда в оставшимся двузначном числе переставили цифры, а затем приписали к ним слева последнюю цифру числа x, то получилось число n.
Ответы (1)
Помогите сделать задание в С++ В трехзначном числе x зачеркнули его последнюю цифру. Когда в оставшемся двузначном числе переставили цифры, а затем приписали к ним слева последнюю цифру числа x, то получилось число n.
Ответы (1)
Дано натуральное число n (n < 9999). Выяснить, различны ли все четыре цифры этого числа (с учетом четырех цифр). Например, в числе 3678 все цифры различны, в числе 0023 - нет.
Ответы (1)