Задать вопрос
6 октября, 01:39

Найти все цифры в записи целого трёхзначного числа

+4
Ответы (2)
  1. 6 октября, 02:54
    0
    mod - берет остаток от деления

    div - берет целое число от деления (отбрасывает остаток)

    По этим функциям можно найти все цифры любого числа. Вот программа которая находит из трёхзначного.

    Var a, b, c, z:integer;

    Begin

    Readln (z) ;

    a:=z mod 10;

    b: = (z mod 100) div 10;

    c: = a div 100;

    Writeln (a, ' ', b, ' ', c, ' ') ;

    End.
  2. 6 октября, 04:47
    0
    Program cifry;

    Var a, x1, x2, x3:integer;

    Begin

    Write ('введите трехзначное число') ;

    Readln (a) ;

    X1:=a div 100;

    X2: = (a div 10) mod 10;

    X3: = a mod 10;

    Writeln ('цифра сотен числа ', а,' равна ', x1) ;

    Writeln ('цифра десятков числа ', а,' равна ', x2) ;

    Writeln ('цифра единиц числа ', а,' равна ', x3) ;

    Readln;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти все цифры в записи целого трёхзначного числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Опишите переменные для размещения в них: - пола человека (один символ) ; - целого положительного двузначного числа; -целого положительного трёхзначного числа; -целого положительного четырёхзначного числа; -небольшого вещественного числа;
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
1) Сколько единиц в двоичной записи числа 67,5? 2) Сколько единиц в двоичной записи числа 23,375? 3) Сколько значащих нулей в двоичной записи числа 19,125? 4) Сколько значащих нулей в двоичной записи числа 37,875?
Ответы (1)
Сумма цифр случайного трехзначного числа (Например, число 123 - это и есть цифры трехзначного числа, для общего случая это будет xyz. Обозначает за x - первое число, y - второе число, z - третье число. Результатом будет r=x+y+z)
Ответы (1)
Числа 1) 2101. 2) - 2101. 3) F840 1. Получить двоичную форму внутреннего представления целого числа в 2-х байтовой ячейке. 2. Получить шестнадцатеричную форму внутреннего представления целого числа в 2-х байтовой ячейке. 3.
Ответы (1)