Задать вопрос
15 мая, 08:35

Помогите составить программу: Сформулировать массив из 12 произвольных чисел. Определить сумму квадратов элементов с чётными индексами. Результат вывести на экран.

+5
Ответы (1)
  1. 15 мая, 09:47
    0
    var a:array [1 ... 100] of integer;

    i, n, s:integer;

    Begin

    randomize;

    n:=12;

    for i: = 1 to n do begin

    a[i]:=random (n*10) - 10*n div 2;

    write (a[i]:4) ;

    if i mod 10=0 then writeln;

    end;

    for i: = 1 to n do begin

    if i mod 2 = 0 then

    s:=s+a[i];

    end;

    writeln (s) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите составить программу: Сформулировать массив из 12 произвольных чисел. Определить сумму квадратов элементов с чётными индексами. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Составить программу, которая заполняет массив А[1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем элементы с четными индексами удваивает, а элементы с нечетными индексами утраивает. Вывести на экран исходный и полученный массив.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Программирование. Паскаль. Массивы 1) Дан массив Р (15). Найти сумму всех отрицательных элементов с четными индексами. Полученный результат вывести на экран. 2) Ввести с пульта оператора массив МАС1 семь целых чисел.
Ответы (1)