Задать вопрос
14 октября, 02:43

Из n случайных чисел в интервале [10; 200) найти количество и сумму нечетных чисел. Написать программу.

+4
Ответы (1)
  1. 14 октября, 05:03
    0
    program name;

    var i, n, x, summa, count:integer;

    begin

    Writeln ('Vvedite n: ') ;

    readln (n) ; / / кол во чисел

    summa:=0;

    count:=0;

    Randomize;

    for i:=1 to n do//цикл выполняется n раз

    begin

    x : = random (189) + 10; //получаем слуайное число из интервала

    if (x mod 2 = 1) then//проверяем число на нечетность, если да то считаем

    begin

    summa:=summa+x;

    count:=count+1;

    writeln ('ne chetnoe') ; / / выводи число четное или нет (можно убрать строку)

    end;

    writeln (x) ; / / пишем само число (можно убрать строку)

    end;

    writeln ('Kolvo: ', count,' summa: ', summa) ; / / выводим сумму и количество

    readln () ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Из n случайных чисел в интервале [10; 200) найти количество и сумму нечетных чисел. Написать программу. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1) Найти сумму нечетных чисел на интервале [-30; 40]. 2) Найти кол-во чисел на интервале [-50; 120], которые кратны 9. 3) Найти произведение чисел кратных 11 на интервале [-10; 20]. 4) Последовательно вводятся N чисел. Найти их произведение.
Ответы (1)
Заполнить массив А (13) датчиком случайных чисел в интервале от 0 до 40 определить количество элементов массива не превосходящих по величине число В число В задается датчиком случайных чисел в интервале от 0 до 20
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)