Задать вопрос
22 мая, 01:25

Имеется четыре произвольных числа a, b, c, d, которые вводятся с клавиатуры. Программа должна давать ответ на вопрос: "Правда ли что первое число меньше остальных" c циклами while repeat

+4
Ответы (1)
  1. 22 мая, 04:01
    0
    Var a, b, c, d, k, f, flag: integer;

    begin

    readln (a, b, c, d) ;

    repeat

    K:=k+1;

    Case k of

    1: f:=b;

    2: f:=c;

    3: f:=d;

    end;

    If a
    else flag:=0;

    Until k=3;

    If flag=3 then Writeln ('yes')

    else writeln ('no') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Имеется четыре произвольных числа a, b, c, d, которые вводятся с клавиатуры. Программа должна давать ответ на вопрос: "Правда ли что первое ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано три числа. Упорядочите их в порядке неубывания. Программа должна считывать три числа a, b, c, затем программа должна менять их значения так, чтобы стали выполнены условия a < = b < = c, затем программа выводит тройку a, b, c.
Ответы (1)
В Python С клавиатуры вводится натуральное число. Программа должна вывести следующее за ним четное число. Например, если ввести 7, то программа должна вывести 8, а если ввести 8, то программа должна вывести 10.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)