Задать вопрос
20 апреля, 15:38

Дан массив целых чисел А (10). Элементы с нечетным индексом заменить минимальным элементом

+5
Ответы (1)
  1. 20 апреля, 19:22
    0
    const n = 10;

    var

    a: array[1 ... n] of integer;

    i, min: integer;

    begin

    min : = 20;

    for i : = 1 to n do begin

    a[i] : = random (20) ;

    if (a[i] < min) then min : = a[i];

    write (a[i], ' ') ;

    end;

    writeln; writeln ('Минимальный эл. массива: ', min) ;

    for i : = 1 to n do begin

    if (i mod 2 0) then a[i] : = min;

    write (a[i], ' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив целых чисел А (10). Элементы с нечетным индексом заменить минимальным элементом ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Перевести числа в десятичную систему счисления 11011,11 с индексом 2 ... 7512,35 с индексом 8 и число FAD, E8 с индексом 16
Ответы (1)
1. Дан массив целых чисел. Все отрицательные элементы заменить положительными. 2. Дан массив целых чисел. Чётные элементы возвести в квадрат остальные разделить пополам
Ответы (1)