Задать вопрос
18 августа, 08:13

в школу привезли компьютеры. к сожалению на всех учителей их не хватает. поэтому было решено провести лотерею. Для этого было выбрано n натуральных чисел а1, а2, аn и число k (1

+2
Ответы (1)
  1. 18 августа, 10:54
    0
    var a:array [1 ... 100] of int;

    i, j, n, t, winners:integer;

    Begin

    writeln ("Введите кол-во делителей") ;

    read (n) ;

    writeln ("Введите k") ;

    read (k) ;

    writeln ("Введите делители") ;

    for i : = 1 to n do

    read (a[i]) ;

    for i: = a to b do begin

    t:=0;

    for j: = 1 to n do

    if i mod a[j] = 0 then t:=t+1;

    if t=k then winners:=winners+1;

    end;

    writeln (winners) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «в школу привезли компьютеры. к сожалению на всех учителей их не хватает. поэтому было решено провести лотерею. Для этого было выбрано n ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Все члены бобрового сообщества недавно купили себе компьютеры. Поиграв немного в компьютерные игры, они захотели общаться друг с другом и решили построить локальную сеть, соединяющую все компьютеры.
Ответы (1)
1. Почему современные персональные компьютеры в сотни раз меньше но при этом в сотни раз быстрее эвм первого поколения? 2. Почему современные персональные компьютеры доступен для массового потребления?
Ответы (1)
Для того чтобы компьютеры поддерживали актуальное время они могут обращаться к серверам точного времени sntp. К сожалению компьютер не может получить время у сервера потому что информация по сети передаётся не мнгновенно
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
напишите программу, которая вычисляет сумму: а) первых n натуральных чисел б) квадраов первых n натуральных чисел в) всех четных чисел в диапозоне от 1 до n г) всех двухзначных чисел
Ответы (1)