Задать вопрос
23 июля, 01:55

Составить программу вычисления средней температуры за месяц

+3
Ответы (2)
  1. 23 июля, 04:22
    0
    Program z;

    uses crt;

    var

    s, x, i:real;

    begin

    clrsc;

    x:=0

    for i:=1 to 30 do begin

    writeln ('введите температуру') ;

    readln (x) ;

    sr:=sr+x;

    end;

    y:=sr/30;

    writeln ('ср темп равна', y) ;

    readln;

    end.
  2. 23 июля, 04:37
    0
    const

    n = 30; / / n - количество дней в месяце

    var

    t: array [1 ... n] of real;

    i: integer;

    s: real;

    begin

    s: = 0;

    for i: = 1 to n do

    begin

    writeln ('Введите температуру ', i, ' дня') ;

    readln (t[i]) ;

    s: = s + t[i];

    end;

    writeln ('Средняя температура за месяц: ', s / n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу вычисления средней температуры за месяц ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
1. Cоставить программу вычисления площади круга: S = п (пи) * R^2 2. Cоставить программу вычисления площади треугольника: S=1/2*A*H 1) Выделить целую часть результата.
Ответы (1)