Задать вопрос
13 июня, 16:49

На заданном пользователем отрезке найти сумму чётных чисел.

+1
Ответы (1)
  1. 13 июня, 19:56
    0
    Var

    a:array [1 ... 1000] of integer;

    i, n, sum:integer;

    begin

    randomize;

    write ('Введите максимальное число массива:') ;

    Readln (n) ;

    begin

    for i:=1 to n do

    a[i]:=random (20) + 20;

    end;

    Writeln ('Массив состоит из следующих чисел:') ;

    for i:=1 to n do

    write (' ', a[i]) ;

    Writeln () ;

    sum:=0;

    for i:=1 to n do

    if a[i] mod 2 = 0 then sum:=a[i]+sum;

    writeln ('Сумма всех чётных чисел равна : ', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «На заданном пользователем отрезке найти сумму чётных чисел. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу которая минимальное значение четных и не четных в заданном диапазоне и сумму и среднее ариф. Всех и четных и нечетных. python3 через цикл while
Ответы (1)
Помогите решить задачи в паскале. 1) найти сумму положительных элементов массива. 2) найти сумму четных элементов массива. 3) найти сумму всех четных элементов массива, стоящих на четных местах.
Ответы (1)
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)
Паскаль. 1) Определите, сколько чисел, введённых пользователем делятся на 3 без остатка. Ввод чисел пользователем заканчивается после ввода цифры 0. 2) Найдите сумму цифр числа, меньших 5. Например, для числа 715245 это будет 1+2+4=7.
Ответы (2)
Паскаль 1. Дано натуральное число N и N целых чисел, задаваемых пользователем. Определить, сколько среди этих N чисел двузначных. Массивы не использовать. 2. Дано натуральное число N и N целых трехзначных чисел, задаваемых пользователем.
Ответы (1)