Задать вопрос
14 октября, 19:09

Составить сумму вычисления:

а) первых n натуральных чисел.

б) первых n четных, первых n нечетных

+2
Ответы (1)
  1. 14 октября, 22:10
    0
    а)

    var i, n, s: integer;

    begin

    readln (n) ;

    s:=0;

    for i:=1 to n do begin

    s:=s+i;

    end;

    writeln (s) ;

    end.

    б)

    var a, n, i, s: integer;

    begin

    readln (n) ;

    s:=0;

    a:=2;

    for i:=1 to n do begin

    s:=s+a;

    a:=a+2

    end;

    writeln ('Сумма первых ', n,' четных чисел равна ', s) ;

    a:=1;

    s:=0;

    for i:=1 to n do begin

    s:=s+a;

    a:=a+2;

    end;

    writeln ('Сумма первых ', n,' нечетных чисел равна ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить сумму вычисления: а) первых n натуральных чисел. б) первых n четных, первых n нечетных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
Задача № 2. Сумма нечетных чисел Вычислить сумму всех нечетных чисел из интервала [a, b]. Например, сумма нечетных чисел из интервала [3, 9] равна 3 + 5 + 7 + 9 = 24.
Ответы (1)
1 вариант. 1. Найти сумму и произведение первых 6 последовательных натуральных чисел. 2. Найти сумму первых k последовательных нечетных чисел. 3. Вывести на экран натуральные нечётные числа от 5 до 55. 4.
Ответы (1)