Задать вопрос
2 февраля, 19:00

Паскаль. Вводится целое число. Найти разность между суммами цифр стоящих на четных и нечетных местах

+1
Ответы (1)
  1. 2 февраля, 19:50
    0
    var

    sn, s, n, c : integer;

    begin

    read (n) ;

    c : = 0; sn : = 0; s : = 0;

    while n > 0 do

    begin

    if c mod 2 = 0 then s : = s + n mod 10

    else sn : = sn + n mod 10;

    n : = n div 10;

    inc (c) ;

    end;

    if c mod 2 = 0 then writeln (s - sn)

    else writeln (sn - s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. Вводится целое число. Найти разность между суммами цифр стоящих на четных и нечетных местах ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Написать программу:"Дано четырехзначное число. Что больше: сумма цифр, стоящих на четных местах, или сумма цифр, стоящих на не четных местах?"
Ответы (1)
Паскаль, помогите! В числовом массиве из 10 элементов, заданных случайным образом от - 100 до 500. Найти: 1) сумму положительных элементов, стоящих на чётных местах; 2) произведение элементов массива, кратных 3 и стоящих на нечётных местах;
Ответы (1)
Имеется целочисленный массив состоящий из N элементов (N - чётное) а) Найти сумму первых N/2 элементов. б) Найти сумму элементов стоящих на чётных позициях. в) Найти произведение элементов стоящих на нечётных позициях.
Ответы (1)
найти сумму элементов стоящих на четных местах и элементов стоящих на нечетных местах в массиве: 3,7,-2,11,6,-3,91,-74,10
Ответы (1)