Задать вопрос
12 мая, 14:04

Ввести с клавиатуры натуральное число N. И с помощью цикла вычислить: 2^N,

N!

+1
Ответы (2)
  1. 12 мая, 16:01
    0
    Program P;

    Var

    I, N : Integer;

    S : Integer;

    Begin

    S : = 1;

    Write ('Enter N ') ;

    ReadLn (N) ;

    for I:=1 to N do

    S : = S * 2;

    WriteLn (S) ;

    ReadLn;

    End.
  2. 12 мая, 16:33
    0
    Program pr;

    uses crt;

    Var n, i:integer;

    s:real;

    Begin

    s:=1;

    Writeln ('Введите n') ;

    readln (n) ;

    For i:=1 to n do

    Begin

    s:=s*2;

    Writeln (s) ;

    end;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ввести с клавиатуры натуральное число N. И с помощью цикла вычислить: 2^N, N! ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сколько раз будет выполнено тело цикла? А. for i:=-5to5 do тело цикла; В. for i:=6 to 2 do тело цикла; С. for i: = 3to 3 do тло цикла; D. for i:=3 downto 4 do тело цикла E. for i : = 3 downto 1 do тело цикла
Ответы (1)
Для чего используются команды цикла? Как записывается команда цикла FOR? Как в цикле записать команду присваивания, чтобы она вычисляла сумму чисел? Количество?
Ответы (2)
1. Ввести с клавиатуры длину и ширину прямоугольной двери. Кроме того, ввести длину, ширину и высоту шкафа - прямоугольного параллелепипеда. Выяснить, можно ли пронести шкаф через дверь, не разбирая его. 2. Ввести три вещественных числа с клавиатуры.
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)