Задать вопрос
20 ноября, 09:54

Найти кол-во 3 х-значных чисел у которых сумма цифр является чётным числом? pascal

+3
Ответы (1)
  1. 20 ноября, 13:26
    0
    var

    i, a, b, c, s : integer;

    begin

    s: = 0;

    for i:=100 to 999 do

    begin

    a: = i div 100;

    b: = (i - a * 100) div 10;

    c: = i mod 10;

    if ((a + b + c) div 2 = 0) then

    s: = s + 1;

    end;

    writeln (s) ;

    end.

    На компе нету паскаля, если что-то неработает пиши

    P. S. Нравится решение? Отметь как лучшее!
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти кол-во 3 х-значных чисел у которых сумма цифр является чётным числом? pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
поставьте знаки арифметических операций в каждой схеме. А) скорость? время=путь б) путь? время=скорость в) масса 1 батона? количество батонов=общ. масса г) кол. батонов? кол. буханок=общ. кол. д) кол. конфет в 1 коробке? кол. коробок = общ. кол.
Ответы (1)
Дано трёхзначное число проверить, будет ли сумма его цифр чётным или не чётным числом.
Ответы (1)
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)