Задать вопрос
4 февраля, 13:29

Составить программу, которая вычисляет сумму и произведение цифр четырехзначного числа

+3
Ответы (1)
  1. 4 февраля, 14:34
    0
    program yourname;

    var a, b, c, d:integer;

    begin

    writeln ('Введите ваше число!') ;

    writeln ('В каждую ячейку можно вписать только однозначное число.') ;

    writeln ('Пример: Число 2341 вводится так: 2 3 4 1.') ;

    readln (a, b, c, d) ;

    writeln ('Ваше число: ', a, b, c, d) ;

    writeln ('Произведение цифр вашего числа: ', a*b*c*d) ;

    writeln ('Сумма цифр вашего числа: ', a+b+c+d) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая вычисляет сумму и произведение цифр четырехзначного числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
2. Составить программу, которая вычисляет количество чисел кратных 3, 4 и 5 одновременно в диапазоне от 1 до 1000. 3. Составить программу, которая вычисляет факториал числа 7!
Ответы (1)
Составить программу, которая вычисляет среднеарифметическое чисел, кратных 3 в диапазоне от 1 до 200. Составить программу, которая вычисляет факториал числа 7!
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию. Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.
Ответы (1)