Задать вопрос
9 июня, 17:19

В заданном массиве к четным элементам прибавить a.

А из элементов с четным номером вычесть b.

+4
Ответы (1)
  1. 9 июня, 18:24
    0
    const n=5;

    var m:array[1 ... n] of integer;

    i, a, b:integer;

    begin

    readln (a, b) ;

    for i:=1 to n do readln (m[i]) ;

    for i:=1 to n do

    if i mod 2 = 0 then m[i]:=m[i]+a

    else m[i]:=m[i]+b;

    for i:=1 to n do

    writeln ('m[', i,']=', m[i]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В заданном массиве к четным элементам прибавить a. А из элементов с четным номером вычесть b. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. заполните одномерный массив B1 размерностью в N (< 30 задает пользователь при выполнении программы) элементов так, чтобы каждый элемент с четным номером был равен половине своего номера, а каждый элемент с нечетным номером - количеству элементов
Ответы (1)
В произвольно заданном одномерном1. В произвольно заданном одномерном массиве (случайные значения из отрезка - 4 до 10) из 13 элементов, определить минимальный элемент и его номер. 2.
Ответы (1)
Паскаль. Вычислить разность максимального среди элементов, имеющих четные значения, и максимального среди элементов, имеющих нечетные значения, в заданном целочисленном массиве из 30 положительных элементов (в предположении, что в массиве есть и
Ответы (1)
Напишите программу вычисления разности максимального среди элементов, имеющих чётные значения, и максимального среди элементов, имеющих нечётные значения, в заданном целочисленном массиве из 10 положительных элементов (в предположении, что в массиве
Ответы (1)
1. В произвольно заданном одномерном массиве (случайные значения из отрезка - 6 до 11) из 6 элементов, определить количество отрицательных, нулевых и положитльных элементов. 2.
Ответы (1)