Задать вопрос
11 февраля, 07:35

Составить программу квадратного уровнения

+3
Ответы (1)
  1. 11 февраля, 08:19
    0
    var a, b, c, D, x1, x2:real;

    begin

    readln (a, b, c) ;

    D:=b*b-4*a*c;

    if D<0 then Writeln ('Только комплексные корни')

    else

    begin

    d:=sqrt (d) ;

    x1: = (-b+d) / (2*a) ;

    x2: = (-b-d) / (2*a) ;

    WriteLn ('x1=', x1) ;

    WriteLn ('x2=', x2) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу квадратного уровнения ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
1) даны 3 числа a, b, c, являющиеся коэффициентами квадратного уравнения. Составить алгоритм и программу для нахождения корней этого квадратного уравнения.
Ответы (1)
Free Pascal 1. Составить программу для вычисления площади прямоугольника по его длинам сторон a и b. 2. Даны два целых числа x и y. Составить программу для нахождения большего из них. 3.
Ответы (1)
Составить программу. дана сторона составить программу. дана сторона квадрата а. найти его площадь и периметр. программу составить в программе паскаль ABC
Ответы (1)