Задать вопрос
10 июня, 03:38

Типизированные файлы, Pascal

1. Ввести с клавиатуры целое число N (>1). Создать файл целых чисел и записать в него N первых положительных четных чисел (2, 4, ...).

2. Вывести содержимое файла на экран.

+5
Ответы (1)
  1. 10 июня, 07:27
    0
    Program n1;

    var n, i: longint;

    t: text;

    s: string;

    begin

    readln (n) ;

    assign (t,'file. txt') ;

    rewrite (t) ;

    for i:=2 to n do if i mod 2=0 then write (t, i,' ') ;

    close (t) ;

    assign (t,'file. txt') ;

    reset (t) ;

    read (t, s) ;

    write (s) ;

    close (t) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Типизированные файлы, Pascal 1. Ввести с клавиатуры целое число N (>1). Создать файл целых чисел и записать в него N первых положительных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу, которая позволяет просматривать текстовые файлы (выводит на экран содержимое файла), например, файлы исходных программ Turbo Pascal. Имя просматриваемого файла должно вводится во время работы программы.
Ответы (1)
1. Прочитать с клавиатуры число n, затем прочитать n чисел и вывести на экран сумму тех из них, которые делятся на 3. 2. Прочитать с клавиатуры число n и вывести на экран сумму его четных цифр 3.
Ответы (1)
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)
Pascal. Тема: Циклы С клавиатуры вводится целое произвольное число 1) Вывести на экран первую и последнюю цифру числа. 2) Вывести на экран наибольшую цифру числа 3) Вывести на экран нечетные цифры этого числа
Ответы (2)
Укажите правильное полное имя файла: А) Текстовый файл song. doc Б) d:/информатика/файлы/word. doc В) текстовый файл D:/информатика/файлы/programma Г) / информатика/файлы/photo. doc
Ответы (1)