Задать вопрос
24 июля, 18:29

Найти сумму положительных элементов в массиве. Использовать процедуру для ввода элементов массива и функцию для подсчета суммы. (решить в паскале)

+2
Ответы (1)
  1. 24 июля, 21:19
    0
    Const n=20;

    type ar=array[1 ... n] of integer;

    procedure p1 (var a:ar) ;

    var i:integer;

    begin

    for i:=1 to n do begin

    a[i]:=random (11) - 5;

    write (a[i],' ') ;

    end;

    writeln;

    end;

    function sum (var a:ar) : integer;

    var s, i:integer;

    begin

    s:=0;

    for i:=1 to n do

    if a[i]>0 then s:=s+a[i];

    sum:=s;

    end;

    var a:ar; p:real;

    begin

    Randomize;

    p1 (a) ;

    writeln ('s = ', sum (a)) ;

    end.

    Пример:

    2 - 4 - 1 3 - 2 - 5 - 1 5 - 5 2 - 1 3 3 - 4 0 4 2 - 1 - 4 - 4

    s = 24
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти сумму положительных элементов в массиве. Использовать процедуру для ввода элементов массива и функцию для подсчета суммы. (решить в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Помогите решить задачи в паскале. 1) найти сумму положительных элементов массива. 2) найти сумму четных элементов массива. 3) найти сумму всех четных элементов массива, стоящих на четных местах.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)