Задать вопрос
23 июня, 19:07

Написать программу, которая вводит натуральное число n и считает сумму чисел от 1 до n

+1
Ответы (2)
  1. 23 июня, 19:18
    0
    Program sum_n;

    var

    n, i, s: integer;

    begin

    write ('n = ') ;

    readln (n) ;

    s : = 0;

    for i : = 1 to n do

    s : = s + i;

    writeln ('s = ', s) ;

    end.
  2. 23 июня, 19:36
    0
    Var

    n:integer;

    S:real;

    Begin

    S:=0;

    Write ('n = ') ;

    ReadLn (n) ;

    For n: = 1 to n do

    S:=S+n;

    Write ('S = ', S)

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая вводит натуральное число n и считает сумму чисел от 1 до n ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая вводит натуральное число N и нахо дит сумму всех натуральных чисел от 1 до N. Используйте сначала цикл с условием, а потом - цикл с переменной.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, сумму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b
Ответы (1)
Простые числа - это натуральные числа, которые делятся без остатка только на себя и на единицу: 2, 3, 5, 7, 11 ... 1) Разработайте программу, которая вводит число К и проверяет, является ли оно простым.
Ответы (1)