Задать вопрос
22 октября, 14:59

В основной программе вводятся стороны треугольника a, b, c. В модуле проверяются неравенства треугольника (a
+1

Ответы (1)
  1. 22 октября, 17:37
    0
    Program n1;

    var a, b, c: real;

    procedure tr (a, b, c: real) ;

    var p, S: real;

    begin

    if (a
    begin

    p:=0.5 * (a+b+c) ;

    S:=sqrt (p * (p-a) * (p-b) * (p-c)) ;

    write ('S=', S:6:3) ;

    end else write ('это не треугольник') ;

    end;

    begin

    readln (a, b, c) ;

    tr (a, b, c) ;

    end.

    / / тестирование:

    ввод: 3 4 5

    вывод: S=6.000

    ввод: 2 3 4

    вывод: S=2.905
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В основной программе вводятся стороны треугольника a, b, c. В модуле проверяются неравенства треугольника (a ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу, сокращающую обыкновенные дроби. Числитель и знаменатель вводятся с клавиатуры. В программе использовать цикл с постусловием. Пример. вводятся числа: 10 15 результат: 2 / 3
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
С клавиатуры вводятся стороны треугольника. Является ли треугольник равнобедренным, нужно ввести в программе Паскаль!
Ответы (1)
Задания по Pascal №1 найти все двузначные числа, такие, что сумма цифр равна A, а само число делится на B. A и B вводятся с клавиатуры. №2 найти сумму всех чисел из промежутка от A до B, кратных 5. A и B вводятся с клавиатуры.
Ответы (1)
1. Вводятся 4 числа целого типа : a b c d. определить наибольшее среди них. 2. последовательно вводятся N целых чисел. найти сумму всех отрицательных среди них.
Ответы (1)