Задать вопрос
15 октября, 13:51

Составить программу в PascalABC

День программиста традиционно отмечается в Беларуси в 256-й день года. Число

256 (28

) выбрано потому, что оно представляет количество различных целых чисел, которые

можно выразить с помощью одного восьмиразрядного байта. А день веб-программиста

ежегодно празднуют 4 апреля. Эта дата также выбрана не случайно: цифры 4.04 очень

напоминают по своему написанию ошибку 404 ("Страница не найдена"), имеющую прямое

отношение к работе веб-мастеров. В нынешнем году, кстати, день веб-программиста

выпадает на вторник, а день программиста - на среду.

В ответе укажите, сколько раз за ближайшие 100 лет оба праздника выпадут на один и

тот же день недели.

+2
Ответы (1)
  1. 15 октября, 15:58
    0
    Const

    names:array[1 ... 7] of string = ('пн','вт','ср','чт','пт','сб','вс') ;

    var k, i, n0, np, nw, year, dw:integer;

    begin

    k:=0;

    n0:=6; / / 01.01.2000 - суббота

    for i:=2000 to 2100 do

    begin

    if (i mod 400=0) or (i mod 4=0) and (i mod 1000)

    then begin year:=366; dw:=31+29+31+3; end

    else begin year:=365; dw:=31+28+31+3; end;

    np: = (255+n0-1) mod 7+1;

    nw: = (dw+n0-1) mod 7+1;

    n0: = (year+n0-1) mod 7+1;

    if np=nw then

    begin writeln (i,' - ', names[np]) ; k:=k+1; end;

    end;

    writeln ('k = ', k) ;

    end.

    Результат:

    2000 - вт

    2004 - вс

    2008 - пт

    ...

    2092 - пт

    2096 - ср

    k = 25

    PS. Високосные годы, однако)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу в PascalABC День программиста традиционно отмечается в Беларуси в 256-й день года. Число 256 (28 ) выбрано потому, что ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
День программиста отмечают 13 сентября, исключение составляет високосный год. Почему выбрана именно эта дата? 1) В этот день была запущена первая программно-управляемая ЭВМ. 2) В этот день была создана первая программа.
Ответы (1)
Укажите упорядоченную по возрастанию последовательность значений Выберите один ответ: 1. 20 бит, 2 байта, 15 бит 2. 2 байта, 15 бит, 20 бит 3. 15 бит, 2 байта, 20 бит 4. 15 бит, 20 бит, 2 байта
Ответы (1)
В каком варианте объёмы памяти расположены в порядке возрастания? 1) 5 бит, 3 байта, 20 бит, 1 Кбайт, 1010 байт 2) 5 бит, 3 байта, 20 бит, 1010 байт, 1 Кбайт 3) 5 бит, 20 бит, 3 байта, 1 Кбайт, 1010 байт 4) 5 бит, 20 бит, 3 байта, 1010 байт, 1 Кбайт
Ответы (1)
Что делает поисковый робот 1 По запросу пользователя быстро заходит на все веб-сайты всемирной паутины и находит из них те, которые содержат слова из запроса пользовател 2 Анализирует содержание веб-страниц и пополняет базу данных информацией о них.
Ответы (2)
Выберите вариант, в котором объемы памяти расположены в порядке возрастания a. 15 бит, 20 бит, 2 байта, 1 Кбайт, 1010 байт b. 15 бит, 2 байта, 20 бит, 1 Кбайт, 1010 байт c. 15 бит, 20 бит, 2 байта, 1010 байт, 1 Кбайт d.
Ответы (1)