Задать вопрос
20 февраля, 09:34

Найти среднее арифметическое элементов в первом столбце в двумерном массиве. Паскаль

+3
Ответы (1)
  1. 20 февраля, 09:52
    0
    const n=3;

    var

    i, j, s, k: integer;

    sa: real;

    a: array [1 ... n, 1 ... n] of integer;

    begin

    writeln ('Ввод элементов матрицы') ;

    for i : = 1 to n do

    for j : = 1 to n do

    begin

    write ('a[', i, ',', j, ']=') ;

    readln (a[i, j]) ;

    end;

    s : = 0; k : = 0;

    for i : = 1 to n do

    for j : = 1 to 1 do

    begin

    s : = s + a[i, j];

    k : = k + 1;

    end;

    sa : = s / k;

    writeln ('Среднее арифметическое элементов матрицы = ', sa:2:2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти среднее арифметическое элементов в первом столбце в двумерном массиве. Паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль 1. В двумерном массиве вычислить A (4,4) найти наибольший элемент, лежащий на главной диагонали. 2. Дан массив A (5,5). Для данного натурального M найти сумму тех элементов массива, сумма индексов которых равна M (М - вводится с клавиатуры).
Ответы (1)
В двумерном массиве найти в двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность (Составить программу)
Ответы (1)
Информатика. Массивы. PascalABC. 1. В двумерном массиве 4 х5 вычислить сумму элементов кратных 3, значения которых больше 20. 2. Найти среднее арифметическое элементов главной диагонали квадратной матрицы 5 х5.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)