Задать вопрос
29 октября, 01:53

Задано целое положительное число. Найдите произведение нечетных цифр числа. Если таких цифр нет, то вывести об этом сообщение

+3
Ответы (1)
  1. 29 октября, 03:10
    0
    Var n, p:integer; f:boolean;

    begin

    write ('n = ') ;

    readln (n) ;

    p:=1;

    f:=false;

    while n>0 do

    begin

    if n mod 2=1

    then begin p:=p * (n mod 10) ; f:=true; end;

    n:=n div 10;

    end;

    if f then writeln ('p = ', p) else writeln ('В числе нет нечетных цифр') ;

    end.

    Пример:

    n = 14538

    p = 15
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задано целое положительное число. Найдите произведение нечетных цифр числа. Если таких цифр нет, то вывести об этом сообщение ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Вводится целое положительное число. Найти наименьшую нечетную цифру в числе. Если в числе нет нечетных цифр, то вывести надпись "В числе нет нечетных цифр"
Ответы (1)
Паскаль, цикл с предусловием while. Вводится целое положительное число. Найти наименьшую нечетную цифру в числе. Если в числе нет нечетных цифр, то вывести надпись "В числе нет нечетных цифр"
Ответы (1)
Играют двое. Первый участник игры называет произвольное целое положительное число, не превышающее десяти, то есть он может назвать число десять и всякое меньшее десяти положительное число.
Ответы (1)
47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя 48 дано целое четырехзначное положительное число n.
Ответы (1)