Задать вопрос
29 марта, 01:12

Напишите на языке программирования паскаль или си либо в виде блок-схемы алгоритм, определяющий являются ли два числа поданных на вход взаимно простыми. в качестве ответа должно быть слово да или нет

+3
Ответы (1)
  1. 29 марта, 02:02
    0
    Program n1;

    var a, b: integer;

    function NOD (m, n:integer) : integer;

    begin

    while mn do

    if m>n then m:=m-n else n:=n-m;

    NOD:=m;

    end;

    begin

    readln (a, b) ;

    if NOD (a, b) = 1 then write ('да')

    else write ('нет') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите на языке программирования паскаль или си либо в виде блок-схемы алгоритм, определяющий являются ли два числа поданных на вход ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Напишите на Паскале, Си или в виде блок-схемы алгоритм, определяющий кол-во различных корней в обобщенном квадратном уравнении. На вход алгоритму подаются коэффициенты a, b, c, на выходе нужно вывести кол-во различных корней.
Ответы (1)
Напишите как решать Ниже на 5 языках программирования записан алгоритм. Получив на вход число х, этот алгоритм печатает число l. Укажите наибольшее нечетное число х, при вводе которого алгоритм печатает 102.
Ответы (1)
Составьте алгоритм решения задачи и представьте его любым удобным Вам способом (на естественном языке, на псевдокоде/алгоритмический язык, в виде блок-схемы или на языке программирования Pascal) 1. С клавиатуры вводятся три целых числа.
Ответы (2)