Задать вопрос
9 ноября, 20:32

1. Заполните массив с клавиатуры А (8). Найти среднее арифметическое элементов массива.

+2
Ответы (1)
  1. 9 ноября, 21:27
    0
    Const

    N = 8;

    Var

    A:array[1 ... N] of integer;

    i:integer;

    S:real;

    Begin

    Write ('Введите массив A (', N,') : ') ;

    For i: = 1 to N do

    Begin

    Read (A[i]) ;

    S:=S+A[i];

    End;

    WriteLn ('Sr = ', S/N) ;

    End.

    Пример работы программы:

    Введите массив A (8) : 1 2 3 4 5 6 7 8

    Sr = 4.5
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Заполните массив с клавиатуры А (8). Найти среднее арифметическое элементов массива. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)