Задать вопрос
19 февраля, 20:20

Написать все четырехзначные натуральные числа, в десятичной записи которых нет двух одинаковых цифр.

+1
Ответы (1)
  1. 19 февраля, 22:54
    0
    Var

    A, r1, r2, r3, r4:integer;

    Begin

    For A: = 1000 to 9999 do

    Begin

    r1:=A div 1000;

    r2: = (A div 100) mod 10;

    r3: = (A div 10) mod 10;

    r4:=A mod 10;

    if (r1r2) and (r1r3) and (r1r4) and (r2r3) and (r2r4) and (r3r4) then

    Write (A,' ')

    End;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать все четырехзначные натуральные числа, в десятичной записи которых нет двух одинаковых цифр. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ребята помогите! Решать пыталась, но прога выводит ошибки! Найти все четырехзначные натуральные числа, у которых сумма крайних цифр равна сумме сред-них цифр, а само число делится на число А.!
Ответы (1)
Программа на с++ Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a, b ], делящиеся на каждую из своих цифр.
Ответы (1)
Перевести в восьмеричную систему счисления. 29,05 (в десятичной) 50,99 (в десятичной) 37,04 (в десятичной) 40,19 (в десятичной) 92,55 (в десятичной)
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)