Задать вопрос
29 апреля, 21:54

Найти сумму квадратов не отрицательных элементов и количество положительных чисел в заданном целочисленном одномерном из 15 элементов

+1
Ответы (1)
  1. 30 апреля, 00:34
    0
    Program n1;

    const n=15;

    var a: array[1 ... n] of integer;

    i, k, sum: integer;

    begin

    randomize;

    k:=0;

    sum:=0;

    writeln ('исходный массив:') ;

    for i:=1 to n do

    begin

    a[i]:=random (21) - 10;

    write (a[i],' ') ;

    if a[i]>0 then

    begin

    k:=k+1;

    sum:=sum+a[i]*a[i];

    end;

    end;

    writeln;

    writeln ('сум. кв. положительных: ', sum) ;

    writeln ('кол-во положительных: ', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти сумму квадратов не отрицательных элементов и количество положительных чисел в заданном целочисленном одномерном из 15 элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В одномерном целочисленном массиве из 10 элементов 1. Найдите количество отрицательных элементов с четными номерами. 2. Найдите произведение элементов, стоящих после 0. Массив нулем не заканчивается. В Pascal
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
В произвольно заданном одномерном массиве (случайные значения из отрезка от - 6 до 11) из 10 элементов, определить количество отрицательных, нулевых и положительных элементов.
Ответы (1)
Паскаль. Вычислить разность максимального среди элементов, имеющих четные значения, и максимального среди элементов, имеющих нечетные значения, в заданном целочисленном массиве из 30 положительных элементов (в предположении, что в массиве есть и
Ответы (1)
Напишите программу вычисления разности максимального среди элементов, имеющих чётные значения, и максимального среди элементов, имеющих нечётные значения, в заданном целочисленном массиве из 10 положительных элементов (в предположении, что в массиве
Ответы (1)