Задать вопрос
26 февраля, 01:35

Задан массив на 10 элементов, все числа вводятся вручную, гарантируется, что все числа натуральные и не превышают 1000, вывести наименьший чётный элемент и его индекс (Паскаль)

+2
Ответы (1)
  1. 26 февраля, 02:47
    0
    Var

    A:array[1 ... 10] of integer;

    i, n, m:integer;

    Begin

    m:=1001;

    WriteLn ('Введите массив') ;

    For i: = 1 to 10 do

    Begin

    Read (A[i]) ;

    if (A[i]
    Begin

    m:=A[i];

    n:=i

    End;

    End;

    WriteLn ('A[', n,'] = ', m) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задан массив на 10 элементов, все числа вводятся вручную, гарантируется, что все числа натуральные и не превышают 1000, вывести наименьший ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сравните. P. S. напишите решение а) 285 (индекс 10) и 11D (индекс 16) б) 111111 (индекс 2) и 1111 (индекс 8) в) 6 С (индекс 16) и 101001 (индекс 2) г) 55 (индекс 16) и 125 (индекс 8)
Ответы (1)
Помогите написать программу! Дан целочисленный массив M из 15 элементов. Элементы массива могут принимать целые значения от - 500 до 500 и вводятся с клавиатуры. Найти и вывести: 1. Сумму квадратов отрицательных элементов.
Ответы (1)
1) ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива 2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
Дан массив А из N целочисленных элементов. 1) Заполнить массив А целыми числами в интервале[1,100] и вывести на экран. Найти максимальный четный элемент и вывести его на экран.
Ответы (1)