Задать вопрос
14 декабря, 05:21

Написать программу которая сумму всех цифр пятизначного числа х который вводится с клавиатуры и определит заканчивается ли эта сумма на три и четная эта сумма или нет

Информатика 8 класс

+4
Ответы (1)
  1. 14 декабря, 05:56
    0
    Program n1;

    var a: longint;

    procedure sumdig (var x: longint) ;

    var s:longint;

    begin

    s:=0;

    while (x0) do

    begin

    s : = s + (x mod 10) ;

    x : = x div 10;

    end;

    if s mod 10=3 then writeln ('оканчивается на 3')

    else writeln ('не оканчивается на 3') ;

    if s mod 2=0 then writeln ('четная') else

    writeln ('нечетная') ;

    end;

    begin

    writeln ('введите целое число') ;

    readln (a) ;

    sumdig (a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу которая сумму всех цифр пятизначного числа х который вводится с клавиатуры и определит заканчивается ли эта сумма на три ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Найти: а) сумму всех целых чисел от 100 до 500; б) сумму всех целых чисел от a до 500 (значение a вводится с клавиатуры; a 500) ; в) сумму всех целых чисел от - 10 до b (значение b вводится с клавиатуры; b - 10) ;
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Я никогда не подружусь с этой темой ... 1. С клавиатуры вводится 7 целых чисел. Найти сумму всех нечетных среди них. 2. С клавиатуры вводится 7 целых чисел. Найти произведение чисел кратных 7. (Информатика. Тема: Pascal ABC. 8 класс)
Ответы (1)