Задать вопрос
2 мая, 16:28

Помогите написать программу на паскале)

сортировка Пузырьком

+2
Ответы (1)
  1. 2 мая, 17:10
    0
    Const

    K = 13;

    Var

    A:array[1 ... K] of integer;

    i, j:integer;

    Begin

    {Заполнение массива}

    Write ('Исходный массив: ') ;

    For i: = 1 to K do

    Begin

    A[i]:=random (21) - 10;

    Write (A[i],' ')

    End;

    WriteLn;

    {Сортировка пузырьком}

    For i: = 1 to K do

    For j: = 1 to K-1 do

    if A[j]>A[j+1] then Swap (A[j], A[j+1]) ;

    {Вывод массива}

    Write ('Отсортированный массив: ') ;

    For i: = 1 to K do

    Write (A[i],' ')

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу на паскале) сортировка Пузырьком ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Чем отличпется функции кнопок Сортировка на панели инструментов от команды Данные-Сортировка в Exsel?
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Помогите написать программу в паскале! Написать программу в паскале: В одномерном массиве из 10 целых чисел вычислить сумму четных чисел ...
Ответы (1)
Зачетная работа по информатике. 1. Написать программу вычисления площади прямоугольника (на паскале). 2. Написать программу вычесления ускорения тела (на паскале).
Ответы (1)
Питон (7 класс). Написать программу: "Сортировка цифр по убыванию в трёхзначном числе". Например: Вводишь число 149 - программа выдаёт тебе 841.
Ответы (1)