Задать вопрос
26 декабря, 09:57

Составьте программу, вычеркивающую из слова Х буквы, встречающиеся при написании слова Х ровно три раза. (паскаль)

+1
Ответы (1)
  1. 26 декабря, 12:07
    0
    Var s:string; c:char; i, j, k:integer;

    begin

    write ('Слово: ') ;

    readln (s) ;

    writeln (s) ;

    i:=1;

    while i
    begin

    k:=0; c:=s[i];

    for j:=1 to length (s) do

    if c=s[j] then k:=k+1;

    if k=3 then

    begin

    while pos (c, s) >0 do delete (s, pos (c, s),1) ;

    i:=i-1;

    end;

    i:=i+1;

    end;

    writeln (s) ;

    end.

    Пример:

    Слово: pnbouipobnpongnf

    pnbouipobnpongnf

    nbuibnngnf
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, вычеркивающую из слова Х буквы, встречающиеся при написании слова Х ровно три раза. (паскаль) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Для заданного массива, состоящего из 100 целых чисел, сначала вывести все числа, встречающиеся в нем несколько раз, а затем все числа, встречающиеся в нем только один раз.
Ответы (1)
По горизонтали: 1. Объект Windows (4, буквы) 2. А4 - это ... (6, буквы) 3. Есть у человека и компьютера. (6, буквы) 4. Начни работу с этой кнопки ... (4, буквы) 5. Чтобы работать с объектом, его надо ... (8, буквы) 6. Есть в ресторане и компьютере.
Ответы (1)