Задать вопрос
12 января, 08:14

Составьте программу, которая определяет число разрядов заданного натурального числа N (подсказка: сколько раз должна выполняться N=N div 10, чтобы получилось N=0)

+1
Ответы (1)
  1. 12 января, 11:28
    0
    Program n1;

    var c: longint;

    function ch (n: longint) : longint;

    var i: longint;

    begin

    i : = 0;

    while n > 0 do

    begin

    n : = n div 10;

    i : = i + 1

    end;

    ch: = i

    end;

    begin

    write ('Введите число: ') ;

    readln (c) ;

    if c<0 then c:=abs (c) ;

    writeln ('в этом числе ', ch (c),' разрядов ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая определяет число разрядов заданного натурального числа N (подсказка: сколько раз должна выполняться N=N div ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы