Задать вопрос
20 ноября, 05:00

Составить программу которая будет вычислять значение выражения у = cosx + cosx^2 + cosx^3 + ... + cosx^n, используя процедуру вычисляющую x в n степени

+4
Ответы (1)
  1. 20 ноября, 07:05
    0
    Процедурой:

    / / Возводит действилельное число x в целую степень n

    Procedure Pow (Const X:real; Const n:integer; Var St:real) ;

    Var i:integer;

    Begin

    St:=1;

    For i: = 1 to n do

    St:=St*x;

    End;

    Var

    x, y, St:real;

    n:integer;

    Begin

    y:=0;

    Write ('x = ') ; ReadLn (x) ;

    Write ('n = ') ; ReadLn (n) ;

    For n: = 1 to n do

    Begin

    Pow (x, n, St) ;

    y:=y+Cos (St) ;

    End;

    WriteLn ('y = ', y) ;

    End.

    Функцией:

    / / Возводит действилельное число x в целую степень n

    Function Pow (Const X:real; Const n:integer) : real;

    Var i:integer;

    Begin

    result:=1;

    For i: = 1 to n do

    result:=result*x;

    End;

    Var

    x, y:real;

    n:integer;

    Begin

    y:=0;

    Write ('x = ') ; ReadLn (x) ;

    Write ('n = ') ; ReadLn (n) ;

    For n: = 1 to n do

    y:=y+Cos (Pow (x, n)) ;

    WriteLn ('y = ', y) ;

    End.

    Циклом:

    Var

    x, y, St:real;

    n:integer;

    Begin

    y:=0;

    Write ('x = ') ; ReadLn (x) ;

    Write ('n = ') ; ReadLn (n) ;

    St:=1;

    For n: = 1 to n do

    Begin

    St:=St*x;

    y:=y+Cos (St) ;

    End;

    WriteLn ('y = ', y) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу которая будет вычислять значение выражения у = cosx + cosx^2 + cosx^3 + ... + cosx^n, используя процедуру вычисляющую x ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Умоляю, помогите с Паскалем 1. Пользователь вводит неотрицательное однозначное число A. Написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом A, вычисляющую в случае ввода 2 - площадь квадрата со стороной A, вычисляющую в
Ответы (1)
1. написать программу, вычисляющую значение функции y=x-24 2. написать программу, вычисляющую значение функции (y=f (x)) y=x-2, если x>0, y=0, если x=0, y=x*x, если x
Ответы (1)