Задать вопрос
6 марта, 14:39

Напишите программу на языке паскаль. Надо заменить меньшее из двух данных чисел на их среднее арифметическое а большее из них на среднее геометрическое.

+4
Ответы (1)
  1. 6 марта, 17:45
    0
    Var

    a, b, sa, sg: real;

    begin

    write ('Введите a ') ; readln (a) ;

    write ('Введите b ') ; readln (b) ;

    sa: = (a + b) / 2;

    sg:=sqrt (a * b) ;

    if a < b then begin

    a : = sa;

    b : = sg;

    end

    else begin

    a : = sg;

    b : = sa;

    end;

    writeln ('a = ', a:0:2, ' ', 'b = ', b:0:2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу на языке паскаль. Надо заменить меньшее из двух данных чисел на их среднее арифметическое а большее из них на среднее ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Линейные алгоритмы. 1. Даны три действительных положительных числа. Найти среднее геометрическое и среднее арифметическое этих чисел. Условный оператор if. 2. Заданы два числа х, у. Меньшее из двух значений заменить на 0.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Описать процедуру Mean (X, Y, AMean, GMean), вычисляющую среднее арифметическое AMean = (X+Y) / 2 и среднее геометрическое двух положительных чисел X и Y (X и Y - входные, AMean и GMean - выходные параметры вещественного типа).
Ответы (1)
1) Написать программу на языке Паскаль, которая вычисляет среднее арифметическое пяти любых чисел. 2) Написать программу на языке Паскаль, вычисляющую корни квадратного уравнения.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)