Задать вопрос
20 мая, 08:10

Основные конструкции языка программирования Паскаль.

Вариант 4.

1. В алгоритме, записанном ниже, используются целочисленные переменные a и b. Oпределите значение переменной a после исполнения данного алгоритма:

a:=-3;

b: = (a+2) * (a+2) ;

a:=2*b-a.

2. Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на Паскале.

Var s, k:integer;

Begin

S:=1;

for k:=1 to 30 do s: = (-1) * s;

writeln (s)

end.

+5
Ответы (1)
  1. 20 мая, 11:52
    0
    1)

    a:=-3

    b: = (-3+2) * (-3+2) = 1

    a:=2*1 - (-3) = 5

    2) Будет выведено число 1
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Основные конструкции языка программирования Паскаль. Вариант 4. 1. В алгоритме, записанном ниже, используются целочисленные переменные a и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)
Как сделать теперь без массива (паскале) ? var nm:array of integer; j, l:integer; begin nm: = new integer[3] (random (20), random (20), random (20)) ; writeln ('nm[0] = ', nm[0]) ; writeln ('nm[1] = ', nm[1]) ; writeln ('nm[2] = ', nm[2]) ;
Ответы (1)
6) Определите, что будет напечатано в результате работы следующего фрагмента программы: var n, s: integer; begin s : = 0; for n:=4 to 13 do begin s : = s + 15; end; write (s) end.
Ответы (1)
4. В алгоритме, записанном ниже, используются целочисленные переменные k и m. Определите значение переменной m после исполнения данного алгоритма: k:=2m:=k-2k:=m*k+5m:=m+2 5.
Ответы (1)
Какое число будет напечатано в результате выполнения программы: var i, k: integer; function f (x: integer) : integer; var m: integer; begin if x < 10 then f : = x else begin m : = f (x div 10) ; if m < x mod 10 then f : = x mod 10 else f : = m; end;
Ответы (1)