Задать вопрос
26 июня, 16:17

1) используя справочник записать значение процедур delete и insert.

2) написать программу позволяющею разделить на отдельные цифры число любой длины

+5
Ответы (1)
  1. 26 июня, 16:55
    0
    1)

    procedure Insert (source: string; var s: string; index: integer) ;

    Вставляет подстроку source в строку s с позиции index procedure Delete (var s: string; index, count: integer) ;

    Удаляет из строки s count символов с позиции index

    2)

    var s:string; i, n, code:integer;

    begin

    write ('Введите длинное число:') ;

    readln (s) ;

    for i:=1 to length (s) do

    begin

    val (s[i], n, code) ;

    if code=0 then writeln (n) ;

    end;

    end.

    Пример:

    Введите длинное число: 3456810285

    3

    4

    5

    6

    8

    1

    0

    2

    8

    5

    Если не требуется выполнять арифметических действий с цифрами, то можно так:

    var s:string; i:integer;

    begin

    write ('Введите длинное число:') ;

    readln (s) ;

    for i:=1 to length (s) do writeln (s[i]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) используя справочник записать значение процедур delete и insert. 2) написать программу позволяющею разделить на отдельные цифры число ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано слово "форматирование". Используя все возможные сначала функции, а потом процедуры получить как можно больше новых слов. Слова составляются на паскале с помощью функций copy, lenght и pos; и процедур delete, insert, str и val.
Ответы (1)
Б) s:='торг'; s1:='ник'; s2:='в'; Insert (s1, s, 4) ; Insert (s2, s, 1) ; Delete (s, 8,1) ; Writeln (s) ;
Ответы (1)
Составьте программу, которая заменяет все буквы "о" на символ "*" в строке s. Использовать можно функции pos, length, copy, delete, insert.
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Клавиша Delete используется: а) удаление выделенного фрагмента текста б) соединения двух абзацев в один в) удаления символа слева о текстового курсора г) удаление символа справа от текстового курсора Каким из способов можно вызвать окно Справка :
Ответы (1)