Задать вопрос
24 ноября, 13:49

Дано четырехзначное число N. Выяснить:

а. Является ли число палиндромом?

б. Верно ли, что все 4 цифры этого числа различны.

+5
Ответы (1)
  1. 24 ноября, 14:16
    0
    Var n, a, b, c, d:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    a:=n div 1000;

    b:=n div 100 mod 10;

    c:=n mod 100 div 10;

    d:=n mod 10;

    if a*10+b=d*10+c

    then writeln ('Число - палиндром')

    else writeln ('Число - не палиндром') ;

    if (ab) and (ac) and (ad) and (bc) and (bd) and (cd)

    then writeln ('В числе все цифры различны')

    else writeln ('В числе есть одинаковые цифры') ;

    end.

    Пример:

    n = 1315

    Число - не палиндром

    В числе есть одинаковые цифры
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано четырехзначное число N. Выяснить: а. Является ли число палиндромом? б. Верно ли, что все 4 цифры этого числа различны. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число n (n < 9999). Выяснить, различны ли все четыре цифры этого числа (с учетом четырех цифр). Например, в числе 3678 все цифры различны, в числе 0023 - нет.
Ответы (1)
Где ошибка? Является ли заданное натуральное четырехзначное число палиндромом? Палиндромами называются числа, которые читаются одинаково слева-направо и справа-налево. Напрмер, 8998, 3333. Вводится целое число N (999 < N
Ответы (1)
Строка является палиндромом, если слева направо и справа налево она читается одинаково, например "кабак", "боб", "asdfggf' dsa". Составьте алгоритм и напишите программу, определяющую, является ли строка палиндромом.
Ответы (1)
1. дано натурально четырехзначное число. определить цифры этого числа (K, L. M. N) и выяснить можно ли построить ромб со сторонами K, L. M. N. в паскале АВС. 2. дано натурально число N вычислить куб суммы этого числа
Ответы (1)
Слово называется палиндромом, если оно читается одинаково, как слева направо, так и справа налево. Требуется определить, какое минимальное количество букв надо добавить к входному слову справа, чтобы оно стало палиндромом.
Ответы (1)