Задать вопрос
7 апреля, 18:16

Паскаль

Даны С, m и массив T (m). Найти число элементов массива Т, меньших С, а для элементов, больших С, найти их среднее арифметическое.

+5
Ответы (1)
  1. 7 апреля, 20:22
    0
    Program n1;

    const m=10;

    var a: array [1 ... m] of integer;

    k, k1, i, sum, c: integer;

    begin

    readln (c) ;

    sum:=0;

    k:=0;

    k1:=0;

    for i:=1 to m do readln (a[i]) ;

    for i:=1 to m do

    begin

    if a[i]
    else

    begin

    sum:=sum + a[i];

    k1:=k1+1;

    end;

    end;

    writeln (k) ;

    writeln (sum/k1) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль Даны С, m и массив T (m). Найти число элементов массива Т, меньших С, а для элементов, больших С, найти их среднее арифметическое. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Массив заполнен случайным образом 20 числами в интервале от 0 до 100. 1) найти максимальный и минимальный элемент массива, а так же их сумму 2) найти среднее арифметическое элементов массива 3) из элементов массива сформировать два массива с четными
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)