Задать вопрос
15 декабря, 06:22

Посчитать сумму чисел, введённых с клавиатуры. Ввод чисел до тех пор, пока не будет значения 0. (С предусловием и постусловием). На языке Паскаль.

+5
Ответы (1)
  1. 15 декабря, 09:41
    0
    Var

    A:integer;

    S:real;

    Begin

    {Постусловие}

    S:=0;

    Repeat

    Read (A) ;

    S:=S+A;

    Until A = 0;

    WriteLn ('S = ', S) ;

    {Предусловие}

    S:=0;

    Read (A) ;

    While A0 do

    Begin

    S:=S+A;

    Read (A) ;

    End;

    WriteLn ('S = ', S) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Посчитать сумму чисел, введённых с клавиатуры. Ввод чисел до тех пор, пока не будет значения 0. (С предусловием и постусловием). На языке ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Осуществить ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён 0) и подсчитать их сумму и среднее арифметическое введённых положительных чисел. Использовать оператор repeat.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчитать количество введённых положительных и отрицательных чисел.
Ответы (1)
Составьте схему алгоритма программы, которая будет осуществлять ввод чисел до тех пор, пока не будет введено число 17. Как только будет введено число 17, программа должна вывести количество введенных чисел
Ответы (1)
составьте программу которая а) выполняет операцию сцепления трех введенных с клавиатуры символов б) выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран.
Ответы (1)