Задать вопрос
8 июля, 20:46

Помогите с задачами

1) является ли число b делителем числа a

2) определить площадь и периметр прямоугольного треугольника по двум сторонам

3) найдите корни квадратного уравнения ax2+bx+c=0 где a b c константы введеные с клавиатуры

4) определить какое из двух чисел ближе к третьему

+1
Ответы (1)
  1. 8 июля, 23:12
    0
    Первая программа:

    Var a, b:integer;

    Begin

    Write ('a = ') ; ReadLn (a) ;

    Write ('b = ') ; ReadLn (b) ;

    if a mod b = 0 then WriteLn (b,' - делитель ', a)

    else WriteLn (b,' не является делителем ', a)

    End.

    Вторая программа:

    Var

    a, b:real;

    Begin

    WriteLn ('a и b - катеты прямоугольного треугольника') ;

    Write ('a = ') ; ReadLn (a) ;

    Write ('b = ') ; ReadLn (b) ;

    WriteLn ('S = ', a*b/2) ;

    WriteLn ('P = ', Sqrt (a*a+b*b) + a+b) ;

    End.

    Пример работы программы:

    a и b - катеты прямоугольного треугольника

    a = 3

    b = 4

    S = 6

    P = 12

    Примечание: программа не проверяет, существует ли треугольник и является ли он прямоугольным.

    Третья программа:

    Var

    a, b, c, D:real;

    Begin

    WriteLn ('ax^2 + bx + c = 0') ;

    Write ('a = ') ; ReadLn (a) ;

    Write ('b = ') ; ReadLn (b) ;

    Write ('c = ') ; ReadLn (c) ;

    D:=b*b-4*a*c;

    if D < 0 then Write ('Действительных корней нет')

    else

    Begin

    WriteLn ('x1 = ', (-b-Sqrt (D)) / (2*a)) ;

    WriteLn ('x2 = ', (-b+Sqrt (D)) / (2*a)) ;

    End

    End.

    Четвёртая программа:

    Var a, b, c:real;

    Begin

    Write ('Введите три числа: ') ; ReadLn (a, b, c) ;

    a:=Abs (a-c) ;

    b:=Abs (b-c) ;

    if a < b then WriteLn ('Первое число ближе к третьему')

    else if a > b then WriteLn ('Второе число ближе к третьему')

    else WriteLn ('Первое и второе число - одинаково близки к третьему')

    End.

    Пример работы программы:

    Введите три числа: 1 2 3

    Второе число ближе к третьему

    Введите три числа: 1 1 3

    Первое и второе число - одинаково близки к третьему

    Введите три числа: 2 1 13

    Первое число ближе к третьему
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите с задачами 1) является ли число b делителем числа a 2) определить площадь и периметр прямоугольного треугольника по двум сторонам ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В выражениях можно использовать: А. Константы, переменные, функции, операторы ввода-вывода. В. Константы, переменные. С. Только числа. D. Константы, переменные, функции.
Ответы (1)
Решить в С# Определить, является ли числоаделителем числа bили, наоборот, число bделителем числа а. Ответом должны служить сообщения "Да, одно из чисел является делителем другого" или "Нет, ни одно из чисел не является делителем другого".
Ответы (1)
1) Что такое константы? 2) Записать число на языке Паскаль: 67,95*10^3 3) Какие из перечисленных переменных неправильные? 3*C; KD; 15RN; A, BC; _beta; My Prog 4) Какие константы неправильные? 0,12; 1/3; 5.0; 15*E3;
Ответы (1)
Пользователь вводит с клавиатуры два числа a и b. Написать программу, определяющую: 1). является ли число a делителем числа b; 2). является ли число b делителем числа a;
Ответы (1)
Проверить являются ли два введенных числа дружественными. Дружественные числа - пара чисел, каждое из которых равно сумме собственных делителей другого (Делителем числа называется всякий его делитель, отличный от самого числа) Дружественные числа
Ответы (1)