Задать вопрос
24 марта, 10:06

Составьте программу (Паскаль) для определения количества цифр в записи произвольного натурального числа. Сейчас проходим while, судя по всему его и надо использовать.

+3
Ответы (1)
  1. 24 марта, 13:07
    0
    Var n, p, k:integer;

    begin

    readln (n) ;

    p:=n;

    while p 0 do begin

    k:=k+1;

    p:=p div 10;

    end;

    writeln ('k=', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу (Паскаль) для определения количества цифр в записи произвольного натурального числа. Сейчас проходим while, судя по ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы