Задать вопрос
31 марта, 04:43

Вычислить значение у. Подсчет вести до тех пор, пока очередной член ряда по модулю не станет меньше E. Значение E должно быть малой величиной порядка 0.001. Значение x, E задавать с клавиатуры.

При решении данного задания необходимо использовать алгоритм с условным циклом. Сама функция

+1
Ответы (1)
  1. 31 марта, 05:38
    0
    Var

    y, x, E, Ch, F, St:real;

    n:integer;

    Begin

    Write ('E = ') ; ReadLn (E) ;

    Write ('x = ') ; ReadLn (x) ;

    y:=0;

    St:=1;

    Ch:=1;

    n:=1;

    F:=1;

    While Ch>=E do

    Begin

    y:=y+Ch;

    F:=F*n;

    St:=St*x;

    Ch:=St/F;

    n:=n+1;

    End;

    Write ('y = ', y)

    End.

    Пример:

    E = 0.001

    x = 13

    y = 442413.391363861
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить значение у. Подсчет вести до тех пор, пока очередной член ряда по модулю не станет меньше E. Значение E должно быть малой ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Если выполнения алгоритма заканчивается, когда условие цикла становится истинным, то он называется: 1) циклом с предусловием 2) бесконечность 3) циклом n-раз 4) циклом с постусловием
Нет ответа
Если данное предложение представить в виде алгоритма то это будет: Если сделаешь уроки, то можешь пойти в кино, иначе сиди дома. А) Линейный алгоритм В) Алгоритм с ветвлением С) Комбинированный алгоритм D) Алгоритм с циклом
Ответы (1)
Алгоритм евклида для вычисления нод двух натуральных чисел формируется так нужно заменять большее число на разность большего и меньшего до тех пор пока одно из них не станет равно нулю тогда второе и есть нод напишите программу которая реализует
Ответы (1)
Алгоритм выполнения домашнего задания. Алгоритм рецепта приготовления пирога. Алгоритм мытья посуды. Алгоритм путешествия Колобка в известной сказке. Оформление.
Ответы (1)
Дан следующий алгоритм: пока впереди Дан следующий алгоритм: пока впереди не край повторять нц поворот кц При каком исходном положении графического исполнителя данный алгоритм зациклится?
Ответы (1)