Задать вопрос
22 декабря, 07:20

Определить все трехзначные числа, которые при делении на 11 дают в частном число, равное сумме квадратов цифр исходного числа.

+3
Ответы (1)
  1. 22 декабря, 09:11
    0
    Var i, j, k:integer;

    begin

    for i:=1 to 9 do

    for j:=0 to 9 do

    for k:=0 to 9 do

    if ((i*100+j*10+k) div 11) = (i*i+j*j+k*k)

    then writeln (i*100+j*10+k) ;

    end.

    Результат:

    131

    241

    324

    550

    624

    803

    900

    910

    Если требуется деление на 11 без остатка, то:

    var i, j, k:integer;

    begin

    for i:=1 to 9 do

    for j:=0 to 9 do

    for k:=0 to 9 do

    if ((i*100+j*10+k) mod 11) = 0 then

    if ((i*100+j*10+k) div 11) = (i*i+j*j+k*k)

    then writeln (i*100+j*10+k) ;

    end.

    Результат:

    550

    803
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить все трехзначные числа, которые при делении на 11 дают в частном число, равное сумме квадратов цифр исходного числа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Написать программу в python: найдите все пятизначные числа, которые при делении на 133 дают в остатке 125, а при делении на 134 дают в остатке 111.
Ответы (1)
Составьте программу поиска трехзначных чисел которые при делении на 43 дают в остатке 41 а при делении на 47 дают в остатке 43
Ответы (1)