Задать вопрос
28 марта, 22:58

Задача 1.

Заполнить массив из 10 элементов случайными значениями от 0 до 100. вывести на экран сумму четных элементов массива.

Задача 2.

Заполнить массив значение с клавиатуры (5 элементов) сумму минимального и максимального элемента.

+1
Ответы (1)
  1. 28 марта, 23:33
    0
    1)

    Program n1;

    const n = 10;

    var m:array [1 ... n] of integer;

    i, sum: integer;

    begin

    randomize;

    sum:=0;

    for i:=1 to n do

    begin

    m[i]:=random (101) ;

    if m[i] mod 2=0 then sum:=sum+m[i];

    end;

    writeln ('сумма четных: ', sum) ;

    end.

    2)

    Program n2;

    const n = 5;

    var m:array [1 ... n] of integer;

    i, min, max : integer;

    begin

    for i:=1 to n do readln (m[i]) ;

    max : = m[1];

    min : = m[1];

    for i : = 1 to n do begin

    if max < m[i] then max : = m[i];

    if min > m[i] then min : = m[i];

    end;

    writeln ('Сумма максимального и минимального: ', max+min) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача 1. Заполнить массив из 10 элементов случайными значениями от 0 до 100. вывести на экран сумму четных элементов массива. Задача 2. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)