Задать вопрос
30 января, 07:34

1) Написать программу для вычисления произведения 30

случайных натуральных чисел. Каждое число принадлежит

промежутку от 0 до 10.

2) Дано натуральное число n. Определить сколько в числе

нулей.

3) Определить значение переменной s после выполнения

следующих операторов, объяснить, как оно получилось.

s:=0;

i:=0;

while i<5 do

i:=i+1;

s:=s+1/i;

4) Найти ошибки в следующем фрагменте программы, если

переменные описаны следующим образом: var x, y: real;

Как их исправить.

y:=0;

for x:=0. 1 to 0. 9 do

y:=y+sin (x) ;

+2
Ответы (1)
  1. 30 января, 10:23
    0
    1)

    Program Product; var a, i:integer; p:Int64; beginrandomize; p:=1; for i:=1 to 30 do begina:=random (9) + 1; p:=p*a; writeln (a) ; end; writeln (p) ; end. 2)

    Program Zero; var a1, a, c:integer; beginreadln (a) ; c:=0; while a>0 dobegina1:=a mod 10; if a1=0 then c:=c+1; a:=a div 10end; writeln (c) ; end. 3) 1 целая 47/60

    4) y:=0;

    x:=0.1

    while x< 0.9 do

    begin

    y:=y+sin (x) ;

    x:=x+0.1;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Написать программу для вычисления произведения 30 случайных натуральных чисел. Каждое число принадлежит промежутку от 0 до 10. 2) Дано ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Запишите на алгоритмическом языке алгоритм, в результате которого переменной A будет присвоено значение переменной B, переменной B-значение переменной C, а переменной C-значение переменной A. Используйте не более одной промежуточной переменной.
Ответы (1)
Написать программу для вычисления произведения 15 случайных натуральных чисел. Каждое число принадлежит промежутку от 1 до 50
Ответы (1)
Написать программу для вычисления суммы от 100 случайных натуральных чисел. Каждое число принадлежит промежутку от 0 до 100
Ответы (1)
С подробным решением 1) определить значение переменной s после выполнения элементов программы: s=0; i=5; do { i=2*i; s=s+i; } while (i5) i=i-1;
Ответы (1)