Задать вопрос
5 марта, 14:44

Помогите написать программу в Pascal, которая вычисляет среднюю оценку за неделю (с помощью массивов)

+4
Ответы (1)
  1. 5 марта, 17:16
    0
    Program n1;

    const n=12;

    var a: array[1 ... n] of integer;

    i, sum: integer;

    begin

    randomize;

    sum:=0;

    write ('оценки за неделю: ') ;

    for i:=1 to n do

    begin

    a[i]:=random (4) + 2;

    write (a[i],' ') ;

    end;

    writeln;

    for i:=1 to n do sum:=sum+a[i];

    writeln ('среднее арифмитическое: ', sum/n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу в Pascal, которая вычисляет среднюю оценку за неделю (с помощью массивов) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов. 2. Написать прогрумму, которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.
Ответы (1)
Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию. Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.
Ответы (1)
2. Составить программу, которая вычисляет количество чисел кратных 3, 4 и 5 одновременно в диапазоне от 1 до 1000. 3. Составить программу, которая вычисляет факториал числа 7!
Ответы (1)
Составить программу, которая вычисляет среднеарифметическое чисел, кратных 3 в диапазоне от 1 до 200. Составить программу, которая вычисляет факториал числа 7!
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)