Задать вопрос
21 августа, 00:00

Написать функцию логического типа, проверяющую, являются ли все цифры, входящие в натуральную запись числа N различными.

pascal

+2
Ответы (1)
  1. 21 августа, 00:51
    0
    Function f (n:integer) : boolean;

    var m:set of 0 ... 9;

    begin

    m:=[];

    f:=true;

    while n>0 do

    begin

    if (n mod 10) in m then f:=false;

    m:=m+[n mod 10];

    n:=n div 10;

    end;

    end;

    begin

    writeln (f (12321)) ;

    end.

    Результат:

    False
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать функцию логического типа, проверяющую, являются ли все цифры, входящие в натуральную запись числа N различными. pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте программу, проверяющую, что введенное число является четным или нечетным 2. Составьте программу, проверяющую, что введенное число делится без остатка на 3
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Имеется два различных типа носителей информации: носитель типа А - с максимальным объемом записываемой на него информации 30 ГБайт, типа В - 680 МБайт.
Ответы (1)
8. Вычислить значение логического выражения, если X = Ложь, У = Истина, Z = Ложь: а) X и не (Z или У) или не Z; б) не X или X и (У или Z) ; в) (X или У и не Z) и Z. 9.
Ответы (1)