Задать вопрос
9 августа, 19:08

Составить программу вычисления максимального и минимального элемента линейного массива состоящего из 14 случайных чисел, принадлежащих диапазону (0; 90]

+1
Ответы (1)
  1. 9 августа, 23:06
    0
    Program PAS;

    Const

    N = 14;

    Var

    A:Array[1 ... N] of integer;

    i, Max, Min:integer;

    Begin

    Randomize;

    Write ('Исходный массив:') ;

    For i: = 1 to N do

    Begin

    A[i]:=random (90) + 1;

    Write (' ', A[i]) ;

    End;

    WriteLn;

    Max:=1;

    Min:=1;

    For i: = 2 to N do

    Begin

    if A[i]>A[Max] then Max:=i;

    if A[i]
    End;

    WriteLn ('Max (A) = A[', Max,'] = ', A[Max]) ;

    WriteLn ('Min (A) = A[', Min,'] = ', A[Min])

    End.

    Пример:

    Исходный массив: 66 70 88 36 30 11 53 1 57 77 6 40 65 46

    Max (A) = A[3] = 88

    Min (A) = A[8] = 1
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу вычисления максимального и минимального элемента линейного массива состоящего из 14 случайных чисел, принадлежащих ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Помогите составить программу в Paskal! 1) Вычислите значение минимального элемента массива 2) Вычислите сумму минисального и максимального элементов 3) Выведите номер минимального элемента 4) Выведите номера максимальных элементов и их количество
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)